Image Stacking
Image Stacking is a powerful technique for extending a photo's apparent depth
of field. Mostly used in close-up and macro photography since the camera
lens's highest f-stop is often insufficient to render everything in focus. But what
you might not be aware of is it can be used in Landscape Photography as well.
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WHEN TO USE IMAGE STACKING
Generally we do not want out-of-focus images. But sometimes, regardless of
which camera settings are used, not every detail of an image can be captured
tack sharp. Depth of field (DOF) can be so shallow, that interesting aspects of
the photos are without sharpness.
When a photographer requires more depth of field, they typically just increase
the f-stop setting of their camera lens. While this is a simple and effective
technique, setting to a smaller aperture will move the aperture farther from a
lens’s sweet spot introducing lens diffraction into the image, again resulting in
some fuzziness. Also, if stopping down the camera’s aperture, shutter speed
will need to be increased and blurry images may result. Increasing ISO to help
with the exposure will introduce digital noise to the image.
So, how do you shoot with the best aperture and shutter speed combination,
and get sharp images from front to back of an image? A technique that can
help resolve this problem is called image stacking.

How to Shoot for Image Stacking
Image stacking is similar in principle to HDR. However, with image stacking,
images are captured with different focus points, and later combined in
Photoshop or another software, to create an image with more DOF than would
be possible with a single exposure.
Landscape and macro photography are two genres of photography that benefit
most from using this procedure. Be warned – calm winds and reasonably
stationary objects are a must!
Before beginning to shoot, it is always helpful to know a lens’s sweet spot,
defined as the aperture that the lens produces its sharpest image. (It is usually
found about two to three stops from wide open.) Experiment until this important
setting is determined.

What You Will Need
A tripod.
A DSLR camera, capable of shooting in Manual Mode, using a lens
capable of Automatic Focus. Manual mode is required to keep shutter
speed, f-stop & ISO at a constant throughout the process.
However, It is possible to use a point and shoot camera, but it must have
manual mode and automatic focus capabilities.
Some type of image stacking software such as Photoshop or Helicon Focus.
Tether cable.

Image Stacking works in three stages:
•
•
•
•

1. Capture
2. Align
3. Merge
Several photos are taken by gradually incrementing the
focusing distance across the subject. The number of separate
photos ranges from a couple (for two distinct layers of subject
matter) to as many as dozens (for expansive scenes). In general,
moving subject matter should be avoided.
• These photos are then aligned so that their content is overlaid
pixel by pixel. This step is necessary even when using a tripod,
since changing the focusing distance always causes misalignment
(more on this later).
• A composite image is then created based on the sharpest
regions from each of these separate photos. If the subject is
composed of only a few distinct layers then this can be performed
manually using layer masks. Otherwise Adobe Photoshop or
specialized software packages such as Helicon Focus, TuFuse or
CombineZM are required.

STAGE 1: Capturing The Photos
•
•

•

•
•
•
•

•

•

•

The most important decision with image stacking is choosing how many photos to take.
In other words, all of the same principles which apply to depth of field also apply here. If your subject
spans a large distance and you plan on making a large print, you'll need a high f-stop to achieve
sufficient depth of field. The only difference is that now you have one more dial under your control: the
number of stacked images. For example, now you can get away with a lower f-stop if you just stack more
images (or vice versa).
One could estimate the number of photos from a formula, but it's probably best to instead develop an
intuition for how many you'll need. If you almost had enough depth of field without image stacking, start
by stacking just 2-3 images with evenly spaced focusing distances across your subject, then see how this
looks. The key is to experiment a lot when starting out.
Near Focus
Middle Focus
Far Focus
Optimal Focusing Distance Spacing. The key is to ensure that the depth of field for each subsequent
photo overlaps with the depth of field from the prior photo. This way no softness will be present in the
final composite. More closely spaced focusing distances often produce more consistent and natural
looking sharpness, but this can take a lot longer to capture and requires more storage space, so try to
avoid overdoing it.
Be extra careful to avoid the wave-like depth of field which can result from focusing distances which are
too widely Also try using the camera's "live view" rear LCD feature for more consistent focus distance
spacing. For advanced stacks, you might want to connect your camera to a laptop (if supported) so that
you can see an enlarged preview and control the focusing distance precisely.
If your subject spans the entire distance from your camera to the distant background, then you'll need to
ensure that you've chosen a span of focusing distances that renders all of this in sharp focus. In this
case, the image stacking technique really needs to be an all or nothing approach, otherwise subjects can
be rendered with an unnatural and abrupt depth of field. The only time you can get away with just a few
focusing distances is when your subject is composed of distinct layers.
Optimal F-Stop. Using higher f-stop values allows for more sparsely spaced focusing distances, but this

STAGE 2: Aligning The Photos
•

Unlike extending the depth of field by varying the f-stop, varying the focusing distance
causes each individual photo to become misaligned. This is because the effective focal
length of a lens actually changes slightly when one alters the focusing distance. As a
result, the angle of view also changes — giving images the appearance of zooming in or
out when focusing near or far, respectively:

•
•

Closer Focusing Distance (narrower angle of view)
Further Focusing Distance (wider angle of view)

•

Special software therefore needs to re-align the separate images.

•

Necessary software packages might include TuFuse, Helicon Focus, CombineZM or some
combination of Adobe Photoshop's Auto-Merge and Auto-Align features. Fortunately, all of
these produce very similar results when aligning images.

•

In Photoshop, you can use either “File>Automate>Photomerge…” or "Edit > Auto-Align
Layers…”

•

If you use Photomerge, then you can effectively perform 2 stages at the same time if you
also check the box that says "Blend Images Together." If the photos were taken on a tripod
(as they should be), then it's best to use the "Collage" option.

•

If you use "Auto-Blend Layers," then you'll need to first ensure that all your photos are
already pasted on top of each other as layers in Photoshop.

STAGE 3: Merging & Blending The
Photos
•

Merging the images requires determining which stacked photo contains the sharpest
representation of each image region.

•

Unfortunately, image merging/blending quality can vary substantially depending on the
image stacking software being used. With a simple subject that has well-defined layers
results will likely be similar. However, whenever the layers are irregular and highly
intertwined, results can vary dramatically. You can always manually edit which photo
contributes where, but this can be quite time consuming. It's therefore recommended that
you first experiment with trial versions of whatever software you're considering.

•

In Photoshop, if you already used Photomerge to align the images, then these photos may
have already been merged if the "blend images together" box was checked. Otherwise you
can blend these as follows:

•

(1) Select layered photos
(2) Go to "Edit > Auto-Blend Layers..." using the top menu, then check "Stack
Images." Result on right:

•

You'll be left with layer masks for each stacked photo (far right image above), so all you
have to do is flatten the image (select all layers and go to "Layer > Flatten Image") and
you'll be left with a sharp, extended depth of field photo. Just in case though, make sure to
closely inspect the final result and edit the layer masks as necessary.

Landscape
There are two basic scenarios when shooting landscapes, that may benefit
from image stacking.
The first is when the subject is a close foreground object, with an interesting
background, both desirable aspects to be in sharp focus.
The second, is when using a telephoto lens (which typically has a shallow
depth of field) and the subject covers multiple distances, that may be brought
into sharper focus. (FYI: If shooting a landscape with a wide angle lens, the
DOF may be adequate enough to capture a sharp image that has no benefit in
being processed by image stacking.)
Tip: Here is a little trick to find out if image stacking will benefit an image when
photographing a scene or subject. After composing the image, set the focus
point about one third into the image. Then, using Live View, enlarge the image
and check to see if the foreground and background are sharp or blurry. If either
or neither are in focus as sharply as desired, the image could benefit from
image stacking.

Steps for Shooting Landscapes
Place the camera on a sturdy tripod – a must!
Frame the subject and compose the shot.
Determine exposure for the scene, and set the camera to manual mode, to
ensure that the exposure is constant for every image.
Set the camera to Live View and aim the focus point on the nearest object
desired to be in image. Use the camera’s zoom (+ button, not zoom on the
lens) to preview the focus through Live View. Then switch to manual focus and
use the focus ring to fine tune for sharpness if necessary.
Take the first exposure.
Without moving the camera or adjusting any settings, move the focus point to
an object mid-way in the image and refocus.
Take the second exposure.
Again, without changing anything, refocus on an object at the farthest
point of the intended image.
Take the third exposure.
To capture landscapes, three images are generally all that is necessary to
create sharp image stacking images, but it’s completely fine to take extra
images to make sure that the entire scenee is covered. A rule of thumb would
be to add more images for longer focal lengths. Be aware that extra images will
take longer to process in post-production.

Macro Photography
Macro photography can benefit from image stacking more than any other type
of photography, because a macro lens has an extremely shallow depth of field.
Place the camera on a sturdy tripod – a must!
Frame the subject and compose the shot.
Determine the exposure for the subject, and set the camera to manual mode
to ensure that the exposure remains constant for each and every image.
Set the camera to Live View and aim the focus point on the nearest object
desired to be in focus. Use the camera’s zoom (+ button, not zoom on the lens)
to preview the focus through Live View. Then switch to manual focus and use
the focus ring to fine tune for sharpness if necessary.
Take the first exposure.
Without moving the camera or adjusting any settings, move the focus point to
a distance slightly farther away from the lens. Remember that DOF in macro
will be measured in fractions of an inch, instead of feet, as in landscape
photography.
Repeat step 6 as many times as needed to cover every aspect of the
subject’s DOF. This could range from as few as six images to 30+ images.
Make sure the entire subject is covered or the results may be unusable.

Image Stacking: Limitations &
Alternatives
•
•
•
•
•
•
•

•

Image stacking is an amazingly powerful technique, but it definitely has
disadvantages:
It can be very time-consuming.
It usually requires the subject matter to be motionless.
It may require a precision focusing device (such as a focusing rail) when
large numbers of photos need to be stacked (such as with extreme macro
photography).
It requires specialized software to align and merge/blend the photos.
Two excellent alternatives include:
Extending Depth of Field by Stacking Images Taken at Different F-stops
This is simpler than image stacking because each image doesn't have to be
aligned, although it cannot extend the depth of field by as much.
Using Tilt Movements with a Tilt/Shift Lens to Reposition the Depth of Field.
This can capture moving subjects, but is limited to situations where the
subject lies along a wedge-shaped region.

Tip: As often used when capturing HDR images, take a shot with your hand in
front of the camera before and after each series of images. When working with
the images later, this will make it easier to tell where each series starts and
ends.

Note: If you are using a Lightroom and Photoshop workflow, after importing
your images into Lightroom, you can simply add all your images into Photoshop
layers by selecting all your images, then Open as Layers In Photoshop. This
will open all the selected images as layers. You will then have to Align your
images by selecting all the layers in the layer palette, then go to Edit/Auto Align
Layers.
Summary
It is nearly every photographer’s intention to capture the sharpest images
possible, and image stacking can be another tool to help you achieve this goal.
The trick to this whole process is to take enough focused images, to create a
final photo that is in focus from foreground to background. The results can be
amazing once you get the hang of it! Give it a try and post your results and any
questions you have here.

Processing Images with Photoshop
Processing the files to accomplish the final image may seem like the most
difficult part of creating a focus stacked image, but it’s really very simple to do
in Photoshop. Here’s how:
Open Photoshop
Get each image on a separate layer: Under File, choose Scripts and Load
files into stack. Click Browse and select all the images.
Check the box for Attempts to Automatically Align Source Images.
Click OK and each of the images will open into a new layer in Photoshop.
Open the Layer palette and select All Layers.
Under Edit, select Auto-Blend Layers.
Check the box for Stack Images and Seamless Tones and Colors.
Optionally, select Content Aware Fill Transparent Areas, which will fill any
transparent areas generated by aligning images in step 3. (Be aware this will
increase processing time. Generally, I do not choose this option; rather, I just
crop the image slightly later, if necessary.)
Click OK
Flatten the image by selecting Layer/Flatten image and save.

Helicon Focus Licenses
Helicon Focus Lite = Helicon Focus Lite license
Helicon Focus Pro Package = Helicon Focus Pro license + Helicon Remote for desktop
computers (Windows, Mac OS X)
Helicon Focus Premium Package = Helicon Focus Pro license + Helicon Remote multiplatform (Windows, Mac OS X, Android, iOS)
One year license is valid during one year after purchase and reverts to demo mode
afterwards. When you upgrade to the unlimited license you get a discount.

Unlimited license is valid for lifetime, all updates are free.
Helicon Focus Lite:
Helicon Focus Pro:
Helicon Focus Premium:

1 year license for $30
1 year license for $55

Unlimited license for $115
Unlimited license for $200
Unlimited license for $240

